旧式の WooCommerce テンプレートの修正

WooCommerce の新しいバージョンがリリースされると、デフォルトのテンプレートが更新されることがあります。

これはメジャーリリース(WooCommerce 2.2 と 2.6)にも適用されますが、マイナーリリース(WooCommerce 2.3.9)にも適用され、WooCommerceのデフォルトテンプレートを上書きするため、テーマの表示がおかしくなる可能性があります。 ほとんどのテーマ作成者はテーマをタイムリーに修正するので、テーマを更新して更新されたテンプレートを取得するだけで済みます。

テーマが更新されていない場合や、テンプレートを変更した場合、または子テーマを使用している場合は、テンプレートを自分で更新する必要があります。

古いテンプレートを更新する方法

更新するテンプレートを決定し、古いテンプレートのバックアップを作成してからカスタマイズを復元する必要があります。

  1. 「WooCommerce」>「システム状況」に移動します。 ページの最後までスクロールすると、テーマ/子テーマで上書きされたテンプレートのリストと、更新が必要な警告メッセージが表示されます。 たとえば、cart-shipping.phpテンプレートは古くなっています:
  2. 古いテンプレートのバックアップを保存します。
  3. wp-content/plugins/woocommerce/templates/[path-to-the-template] からデフォルトのテンプレートをコピーし、wp-content/themes/[path-to-theme] にあるテーマフォルダに貼り付けます。
  4. テーマフォルダに貼り付けたテンプレートをメモ帳などの選択したテキストエディタで開き、以前のテンプレートに加えた変更を更新した新しいテンプレートファイルに複製します。

このようなことをするには時間がかかることがあることを認識しています。 このため、 WooCommerce テンプレートを変更しないようにしようとしていますが、下位互換性をなくしてしまう方が賢明な場合もあります。

よくある質問

WooCommerce の最新バージョンはどこにありますか?

更新に使用する既定のテンプレートを探している場合は、最新バージョンの WooCommerce を使用する必要があります。 テンプレートを取得するには、いくつかの簡単な方法があります。

  1. あなたの現在のWooCommerceのインストールは最新のものでなければならないので、ファイルはあなたのサイトでFTP経由でアクセス可能です
  2. WordPress.orgから最新バージョンをダウンロードする
  3. Githubリポジトリからすべてのバージョンをダウンロードする

英語原文(Fixing Outdated WooCommerce Templates)